import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^\"]+)\":[\"]*([^,^\\}^\"]+)";
final String string = "[{\"name\":\"Піксель ТВ\",\"url\":\"http://st.it-tv.org:4575/?224.1.16.33\",\"type\":81,\"tsOn\":false}]";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}