re = /include.*[\'\"]([\w-\/.]+)(?:.|\s+)*?[\'\"]/
str = 'h1
=title
include \'atoms-square\'
#container.col
if youAreUsingJade
p You are amazing
else
p Get on it!
p.
Jade is a terse and simple
templating language with a
strong focus on performance
and powerful features.
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end