const regex = /include.*[\'\"]([\w-\/.]+)(?:.|\s+)*?[\'\"]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('include.*[\\\'\\"]([\\w-\\\/.]+)(?:.|\\s+)*?[\\\'\\"]', '')
const str = `h1
=title
include 'atoms-square'
#container.col
if youAreUsingJade
p You are amazing
else
p Get on it!
p.
Jade is a terse and simple
templating language with a
strong focus on performance
and powerful features.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}