package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`include.*[\'\"]([\w-\/.]+)(?:.|\s+)*?[\'\"]`)
var str = `h1
=title
include 'atoms-square'
#container.col
if youAreUsingJade
p You are amazing
else
p Get on it!
p.
Jade is a terse and simple
templating language with a
strong focus on performance
and powerful features.
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}