import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "include.*[\\'\\\"]([\\w-\\/.]+)(?:.|\\s+)*?[\\'\\\"]";
final String string = "h1\n"
+ " =title\n"
+ " include 'atoms-square'\n"
+ "#container.col\n"
+ " if youAreUsingJade\n"
+ " p You are amazing\n"
+ " else\n"
+ " p Get on it!\n"
+ " p.\n"
+ " Jade is a terse and simple\n"
+ " templating language with a\n"
+ " strong focus on performance\n"
+ " and powerful features.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}