#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "include.*[\'\"]([\w-\/.]+)(?:.|\s+)*?[\'\"]"
Local $sString = "h1" & @CRLF & _
" =title" & @CRLF & _
" include 'atoms-square'" & @CRLF & _
"#container.col" & @CRLF & _
" if youAreUsingJade" & @CRLF & _
" p You are amazing" & @CRLF & _
" else" & @CRLF & _
" p Get on it!" & @CRLF & _
" p." & @CRLF & _
" Jade is a terse and simple" & @CRLF & _
" templating language with a" & @CRLF & _
" strong focus on performance" & @CRLF & _
" and powerful features." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")