using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"include.*[\'\""]([\w-\/.]+)(?:.|\s+)*?[\'\""]";
string input = @"h1
=title
include 'atoms-square'
#container.col
if youAreUsingJade
p You are amazing
else
p Get on it!
p.
Jade is a terse and simple
templating language with a
strong focus on performance
and powerful features.
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}