// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:\+|0|\(\d+\)) ?(?:[0-9] ?){6,14}[0-9]$").unwrap();
let string = "+49 711 4 20 42 26";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}