const regex = /^(?:\+|0|\(\d+\)) ?(?:[0-9] ?){6,14}[0-9]$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+|0|\\(\\d+\\)) ?(?:[0-9] ?){6,14}[0-9]$', '')
const str = `+49 711 4 20 42 26`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);