using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\+|0|\(\d+\)) ?(?:[0-9] ?){6,14}[0-9]$";
string substitution = @"";
string input = @"+49 711 4 20 42 26";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}