# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\+|0|\(\d+\)) ?(?:[0-9] ?){6,14}[0-9]$//;t' <<< "+49 711 4 20 42 26"