re = /^(?:\+|0|\(\d+\)) ?(?:[0-9] ?){6,14}[0-9]$/
str = '+49 711 4 20 42 26'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result