$re = '/^(?:\+|0|\(\d+\)) ?(?:[0-9] ?){6,14}[0-9]$/';
$str = '+49 711 4 20 42 26';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;