import Foundation
let pattern = #"[^a-zA-Z0-9\'\s]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"VID RTE_$gagagaga6666"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)