use strict;
my $str = 'VID RTE_$gagagaga6666';
my $regex = qr/[^a-zA-Z0-9\'\s]/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";