using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-zA-Z0-9\'\s]";
string substitution = @" ";
string input = @"VID RTE_$gagagaga6666";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}