#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^a-zA-Z0-9\'\s]"
Local $sString = "VID RTE_$gagagaga6666"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)