$re = '/[^a-zA-Z0-9\'\s]/';
$str = 'VID RTE_$gagagaga6666';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;