package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^a-zA-Z0-9\'\s]`)
var str = `VID RTE_$gagagaga6666`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}