re = /^(?!.*nlp)(?=.*(find|want))(?=.*string).*$/m
str = 'I find module that string processing for nlp project
I find module that string processing
I want module that string processing
I find module that processing
I module that string processing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end