#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*nlp)(?=.*(find|want))(?=.*string).*$"
Local $sString = "I find module that string processing for nlp project" & @CRLF & _
"I find module that string processing" & @CRLF & _
"I want module that string processing" & @CRLF & _
"I find module that processing" & @CRLF & _
"I module that string processing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")