$re = '/^(?!.*nlp)(?=.*(find|want))(?=.*string).*$/m';
$str = 'I find module that string processing for nlp project
I find module that string processing
I want module that string processing
I find module that processing
I module that string processing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);