using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*nlp)(?=.*(find|want))(?=.*string).*$";
string input = @"I find module that string processing for nlp project
I find module that string processing
I want module that string processing
I find module that processing
I module that string processing";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}