const regex = new RegExp('^(?!.*nlp)(?=.*(find|want))(?=.*string).*$', 'gm')
const str = `I find module that string processing for nlp project
I find module that string processing
I want module that string processing
I find module that processing
I module that string processing`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}