import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*nlp)(?=.*(find|want))(?=.*string).*$";
final String string = "I find module that string processing for nlp project\n"
+ "I find module that string processing\n"
+ "I want module that string processing\n"
+ "I find module that processing\n"
+ "I module that string processing";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}