import Foundation
let pattern = #"(\d{4}-\d{2}-\d{2})(\s|T|t)(\d{2}:\d{2}(?::\d{2})?)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2016-02-01
2016-02-01 00:00
2016-02-01T00:00
2016-11-10 12:30:11
2016-02-01T12:30:11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)