#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{4}-\d{2}-\d{2})(\s|T|t)(\d{2}:\d{2}(?::\d{2})?)?"
Local $sString = "2016-02-01" & @CRLF & _
"2016-02-01 00:00" & @CRLF & _
"2016-02-01T00:00" & @CRLF & _
"" & @CRLF & _
"2016-11-10 12:30:11" & @CRLF & _
"2016-02-01T12:30:11" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")