import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}-\\d{2}-\\d{2})(\\s|T|t)(\\d{2}:\\d{2}(?::\\d{2})?)?";
final String string = "2016-02-01\n"
+ "2016-02-01 00:00\n"
+ "2016-02-01T00:00\n\n"
+ "2016-11-10 12:30:11\n"
+ "2016-02-01T12:30:11\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}