const regex = /(\d{4}-\d{2}-\d{2})(\s|T|t)(\d{2}:\d{2}(?::\d{2})?)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4}-\\d{2}-\\d{2})(\\s|T|t)(\\d{2}:\\d{2}(?::\\d{2})?)?', 'g')
const str = `2016-02-01
2016-02-01 00:00
2016-02-01T00:00
2016-11-10 12:30:11
2016-02-01T12:30:11
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}