using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4}-\d{2}-\d{2})(\s|T|t)(\d{2}:\d{2}(?::\d{2})?)?";
string input = @"2016-02-01
2016-02-01 00:00
2016-02-01T00:00
2016-11-10 12:30:11
2016-02-01T12:30:11
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}