package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{4}-\d{2}-\d{2})(\s|T|t)(\d{2}:\d{2}(?::\d{2})?)?`)
var str = `2016-02-01
2016-02-01 00:00
2016-02-01T00:00
2016-11-10 12:30:11
2016-02-01T12:30:11
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}