# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)([<[]Assembly: Assembly(File|Informational)?Version)\(\"[^\"]*\"\)"
test_str = ("# C#\n"
"[assembly: AssemblyCopyright(\"\")]\n"
"[assembly: AssemblyTrademark(\"\")]\n"
"[assembly: AssemblyCulture(\"\")]\n"
"[assembly: AssemblyVersion(\"1.1.0.0\")]\n"
"[assembly: AssemblyDelaySign(false)]\n"
"[assembly: AssemblyKeyFile(\"\")]\n"
"[assembly: AssemblyKeyName(\"\")]\n"
"[assembly: AssemblyInformationalVersion(\"1.0.0 JRC\")]\n\n"
"# VBasic\n"
"<Assembly: AssemblyCulture(\"\")>\n"
"<Assembly: AssemblyVersion(\"1.1.0.0\")]\n"
"<Assembly: AssemblyDelaySign(false)]\n"
"<Assembly: AssemblyKeyFile(\"\")>\n"
"<Assembly: AssemblyKeyName(\"\")>\n"
"<Assembly: AssemblyInformationalVersion(\"1.0.0 JRC\")>\n")
subst = "\\1(\"0.1.2.3\")"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.