import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)([<[]Assembly: Assembly(File|Informational)?Version)\\(\\\"[^\\\"]*\\\"\\)";
final String string = "# C#\n"
+ "[assembly: AssemblyCopyright(\"\")]\n"
+ "[assembly: AssemblyTrademark(\"\")]\n"
+ "[assembly: AssemblyCulture(\"\")]\n"
+ "[assembly: AssemblyVersion(\"1.1.0.0\")]\n"
+ "[assembly: AssemblyDelaySign(false)]\n"
+ "[assembly: AssemblyKeyFile(\"\")]\n"
+ "[assembly: AssemblyKeyName(\"\")]\n"
+ "[assembly: AssemblyInformationalVersion(\"1.0.0 JRC\")]\n\n"
+ "# VBasic\n"
+ "<Assembly: AssemblyCulture(\"\")>\n"
+ "<Assembly: AssemblyVersion(\"1.1.0.0\")]\n"
+ "<Assembly: AssemblyDelaySign(false)]\n"
+ "<Assembly: AssemblyKeyFile(\"\")>\n"
+ "<Assembly: AssemblyKeyName(\"\")>\n"
+ "<Assembly: AssemblyInformationalVersion(\"1.0.0 JRC\")>\n";
final String subst = "\\1(\"0.1.2.3\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}