#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?i)([<[]Assembly: Assembly(File|Informational)?Version)\(\"[^\"]*\"\)"
Local $sString = "# C#" & @CRLF & _
"[assembly: AssemblyCopyright("")]" & @CRLF & _
"[assembly: AssemblyTrademark("")]" & @CRLF & _
"[assembly: AssemblyCulture("")]" & @CRLF & _
"[assembly: AssemblyVersion("1.1.0.0")]" & @CRLF & _
"[assembly: AssemblyDelaySign(false)]" & @CRLF & _
"[assembly: AssemblyKeyFile("")]" & @CRLF & _
"[assembly: AssemblyKeyName("")]" & @CRLF & _
"[assembly: AssemblyInformationalVersion("1.0.0 JRC")]" & @CRLF & _
"" & @CRLF & _
"# VBasic" & @CRLF & _
"<Assembly: AssemblyCulture("")>" & @CRLF & _
"<Assembly: AssemblyVersion("1.1.0.0")]" & @CRLF & _
"<Assembly: AssemblyDelaySign(false)]" & @CRLF & _
"<Assembly: AssemblyKeyFile("")>" & @CRLF & _
"<Assembly: AssemblyKeyName("")>" & @CRLF & _
"<Assembly: AssemblyInformationalVersion("1.0.0 JRC")>" & @CRLF & _
""
Local $sSubst = "\1("0.1.2.3")"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)