# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)([<[]Assembly: Assembly(File|Informational)?Version)\(\"[^\"]*\"\)/\1("0.1.2.3")/gm;t' <<< "# C#
[assembly: AssemblyCopyright(\"\")]
[assembly: AssemblyTrademark(\"\")]
[assembly: AssemblyCulture(\"\")]
[assembly: AssemblyVersion(\"1.1.0.0\")]
[assembly: AssemblyDelaySign(false)]
[assembly: AssemblyKeyFile(\"\")]
[assembly: AssemblyKeyName(\"\")]
[assembly: AssemblyInformationalVersion(\"1.0.0 JRC\")]
# VBasic
<Assembly: AssemblyCulture(\"\")>
<Assembly: AssemblyVersion(\"1.1.0.0\")]
<Assembly: AssemblyDelaySign(false)]
<Assembly: AssemblyKeyFile(\"\")>
<Assembly: AssemblyKeyName(\"\")>
<Assembly: AssemblyInformationalVersion(\"1.0.0 JRC\")>
"