package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)([<[]Assembly: Assembly(File|Informational)?Version)\(\"[^\"]*\"\)`)
var str = `# C#
[assembly: AssemblyCopyright("")]
[assembly: AssemblyTrademark("")]
[assembly: AssemblyCulture("")]
[assembly: AssemblyVersion("1.1.0.0")]
[assembly: AssemblyDelaySign(false)]
[assembly: AssemblyKeyFile("")]
[assembly: AssemblyKeyName("")]
[assembly: AssemblyInformationalVersion("1.0.0 JRC")]
# VBasic
<Assembly: AssemblyCulture("")>
<Assembly: AssemblyVersion("1.1.0.0")]
<Assembly: AssemblyDelaySign(false)]
<Assembly: AssemblyKeyFile("")>
<Assembly: AssemblyKeyName("")>
<Assembly: AssemblyInformationalVersion("1.0.0 JRC")>
`
var substitution = "\1("0.1.2.3")"
fmt.Println(re.ReplaceAllString(str, substitution))
}