import Foundation
let pattern = #"\* STATUS (?|(?:\"([^\r\n]+)\")|(\S+)|(?:\{\d+\}\r\n(.*))) \(MESSAGES (\d+) UNSEEN (\d+)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
* STATUS "INBOX.&jspOIQ-" (MESSAGES 2 UNSEEN 1)
* STATUS "&jspOIQ-" (MESSAGES 3 UNSEEN 1)
* STATUS {14}
INBOX."quotes" (MESSAGES 6 UNSEEN 1)
* STATUS {8}
"quotes" (MESSAGES 10 UNSEEN 1)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)