using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\* STATUS (?|(?:\""([^\r\n]+)\"")|(\S+)|(?:\{\d+\}\r\n(.*))) \(MESSAGES (\d+) UNSEEN (\d+)\)";
string input = @"* STATUS ""INBOX.&jspOIQ-"" (MESSAGES 2 UNSEEN 1)
* STATUS ""&jspOIQ-"" (MESSAGES 3 UNSEEN 1)
* STATUS {14}
INBOX.""quotes"" (MESSAGES 6 UNSEEN 1)
* STATUS {8}
""quotes"" (MESSAGES 10 UNSEEN 1)
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}