#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\* STATUS (?|(?:\"([^\r\n]+)\")|(\S+)|(?:\{\d+\}\r\n(.*))) \(MESSAGES (\d+) UNSEEN (\d+)\)"
Local $sString = "* STATUS "INBOX.&jspOIQ-" (MESSAGES 2 UNSEEN 1)" & @CRLF & _
"" & @CRLF & _
"* STATUS "&jspOIQ-" (MESSAGES 3 UNSEEN 1)" & @CRLF & _
"" & @CRLF & _
"* STATUS {14}" & @CRLF & _
"INBOX."quotes" (MESSAGES 6 UNSEEN 1)" & @CRLF & _
"" & @CRLF & _
"* STATUS {8}" & @CRLF & _
""quotes" (MESSAGES 10 UNSEEN 1)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")