import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\* STATUS (?|(?:\\\"([^\\r\\n]+)\\\")|(\\S+)|(?:\\{\\d+\\}\\r\\n(.*))) \\(MESSAGES (\\d+) UNSEEN (\\d+)\\)";
final String string = "* STATUS \"INBOX.&jspOIQ-\" (MESSAGES 2 UNSEEN 1)\n\n"
+ "* STATUS \"&jspOIQ-\" (MESSAGES 3 UNSEEN 1)\n\n"
+ "* STATUS {14}\n"
+ "INBOX.\"quotes\" (MESSAGES 6 UNSEEN 1)\n\n"
+ "* STATUS {8}\n"
+ "\"quotes\" (MESSAGES 10 UNSEEN 1)\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}