$re = '/\* STATUS (?|(?:\"([^\r\n]+)\")|(\S+)|(?:\{\d+\}\r\n(.*))) \(MESSAGES (\d+) UNSEEN (\d+)\)/i';
$str = '* STATUS "INBOX.&jspOIQ-" (MESSAGES 2 UNSEEN 1)
* STATUS "&jspOIQ-" (MESSAGES 3 UNSEEN 1)
* STATUS {14}
INBOX."quotes" (MESSAGES 6 UNSEEN 1)
* STATUS {8}
"quotes" (MESSAGES 10 UNSEEN 1)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);