use strict;
my $str = '* STATUS "INBOX.&jspOIQ-" (MESSAGES 2 UNSEEN 1)
* STATUS "&jspOIQ-" (MESSAGES 3 UNSEEN 1)
* STATUS {14}
INBOX."quotes" (MESSAGES 6 UNSEEN 1)
* STATUS {8}
"quotes" (MESSAGES 10 UNSEEN 1)
';
my $regex = qr/\* STATUS (?|(?:\"([^\r\n]+)\")|(\S+)|(?:\{\d+\}\r\n(.*))) \(MESSAGES (\d+) UNSEEN (\d+)\)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}