re = /(?<!=\")\b((?:http|https|ftp):\/\/)((?:(?:\w)+\.)+(?:\w)+)(:\d+)?((?:\/[\w]+)*[.\w]*\/?)((?:[\?\w\=\_\-%+!$^*\/\\@#;:]|(?:&(?!gt;)|(?:['"](?=[\w"'&#,]))))*)/
str = '<http://www.google.com.edu:8080/path/to/ting.this?this=that&that=this#21>
<http://www.google.com/path/to/thing/?this=that&that=this#21>
http://google.com
https://www.yy.sdf.yahoo.com.sdf.s.dsf.cat/
"ftp://msn.com/path.thing"
\'http://askdeeves.com/sdf?asdf="sdf"&cat=blue\'
<http://ask.com#21>
href="http://askdeeves.com/sdf?asdf="sdf"&cat=blue"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end