use strict;
my $str = '<http://www.google.com.edu:8080/path/to/ting.this?this=that&that=this#21>
<http://www.google.com/path/to/thing/?this=that&that=this#21>
http://google.com
https://www.yy.sdf.yahoo.com.sdf.s.dsf.cat/
"ftp://msn.com/path.thing"
\'http://askdeeves.com/sdf?asdf="sdf"&cat=blue\'
<http://ask.com#21>
href="http://askdeeves.com/sdf?asdf="sdf"&cat=blue"
';
my $regex = qr/(?<!=\")\b((?:http|https|ftp):\/\/)((?:(?:\w)+\.)+(?:\w)+)(:\d+)?((?:\/[\w]+)*[.\w]*\/?)((?:[\?\w\=\_\-%+!$^*\/\\@#;:]|(?:&(?!gt;)|(?:['"](?=[\w"'&#,]))))*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}