#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!=\")\b((?:http|https|ftp):\/\/)((?:(?:\w)+\.)+(?:\w)+)(:\d+)?((?:\/[\w]+)*[.\w]*\/?)((?:[\?\w\=\_\-%+!$^*\/\\@#;:]|(?:&(?!gt;)|(?:['"](?=[\w"'&#,]))))*)"
Local $sString = "<http://www.google.com.edu:8080/path/to/ting.this?this=that&that=this#21> " & @CRLF & _
"<http://www.google.com/path/to/thing/?this=that&that=this#21>" & @CRLF & _
"http://google.com" & @CRLF & _
"https://www.yy.sdf.yahoo.com.sdf.s.dsf.cat/" & @CRLF & _
""ftp://msn.com/path.thing"" & @CRLF & _
"'http://askdeeves.com/sdf?asdf="sdf"&cat=blue'" & @CRLF & _
"<http://ask.com#21> " & @CRLF & _
"href="http://askdeeves.com/sdf?asdf="sdf"&cat=blue"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")