import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!=\\\")\\b((?:http|https|ftp):\\/\\/)((?:(?:\\w)+\\.)+(?:\\w)+)(:\\d+)?((?:\\/[\\w]+)*[.\\w]*\\/?)((?:[\\?\\w\\=\\_\\-%+!$^*\\/\\\\@#;:]|(?:&(?!gt;)|(?:['\"](?=[\\w\"'&#,]))))*)";
final String string = "<http://www.google.com.edu:8080/path/to/ting.this?this=that&that=this#21> \n"
+ "<http://www.google.com/path/to/thing/?this=that&that=this#21>\n"
+ "http://google.com\n"
+ "https://www.yy.sdf.yahoo.com.sdf.s.dsf.cat/\n"
+ "\"ftp://msn.com/path.thing\"\n"
+ "'http://askdeeves.com/sdf?asdf=\"sdf\"&cat=blue'\n"
+ "<http://ask.com#21> \n"
+ "href=\"http://askdeeves.com/sdf?asdf=\"sdf\"&cat=blue\"\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}