using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!=\"")\b((?:http|https|ftp):\/\/)((?:(?:\w)+\.)+(?:\w)+)(:\d+)?((?:\/[\w]+)*[.\w]*\/?)((?:[\?\w\=\_\-%+!$^*\/\\@#;:]|(?:&(?!gt;)|(?:['""](?=[\w""'&#,]))))*)";
string input = @"<http://www.google.com.edu:8080/path/to/ting.this?this=that&that=this#21>
<http://www.google.com/path/to/thing/?this=that&that=this#21>
http://google.com
https://www.yy.sdf.yahoo.com.sdf.s.dsf.cat/
""ftp://msn.com/path.thing""
'http://askdeeves.com/sdf?asdf=""sdf""&cat=blue'
<http://ask.com#21>
href=""http://askdeeves.com/sdf?asdf=""sdf""&cat=blue""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}