const regex = /(?<!=\")\b((?:http|https|ftp):\/\/)((?:(?:\w)+\.)+(?:\w)+)(:\d+)?((?:\/[\w]+)*[.\w]*\/?)((?:[\?\w\=\_\-%+!$^*\/\\@#;:]|(?:&(?!gt;)|(?:['"](?=[\w"'&#,]))))*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!=\\")\\b((?:http|https|ftp):\\\/\\\/)((?:(?:\\w)+\\.)+(?:\\w)+)(:\\d+)?((?:\\\/[\\w]+)*[.\\w]*\\\/?)((?:[\\?\\w\\=\\_\\-%+!$^*\\\/\\\\@#;:]|(?:&(?!gt;)|(?:[\'"](?=[\\w"\'&#,]))))*)', 'g')
const str = `<http://www.google.com.edu:8080/path/to/ting.this?this=that&that=this#21>
<http://www.google.com/path/to/thing/?this=that&that=this#21>
http://google.com
https://www.yy.sdf.yahoo.com.sdf.s.dsf.cat/
"ftp://msn.com/path.thing"
'http://askdeeves.com/sdf?asdf="sdf"&cat=blue'
<http://ask.com#21>
href="http://askdeeves.com/sdf?asdf="sdf"&cat=blue"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}