// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(thank-you$)|(thank-you\?)|(thank-you\/\?)").unwrap();
let string = "thank-you
thank
thank-you?
thank-you-for
thank-you/again
thank-you/?
aries-thank-you";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}