re = /(thank-you$)|(thank-you\?)|(thank-you\/\?)/m
str = 'thank-you
thank
thank-you?
thank-you-for
thank-you/again
thank-you/?
aries-thank-you'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end